Issue
Symantec Installation Manager (SIM) tries to change to the Arellia Product Listing (PL) but ends up switching back to the Product listing PL it was already on
Resolution
- Remove and save the files InstallHistoryPl.xml and InstallHistoryPl.xml.bak from the \Altiris\Symantec Installation Manager\
...
- directory.
- Or just rename them (to something like InstallHistoryPl.xml.Symantec and InstallHistoryPl.xml.bak.Symantec) and leave them in the directory.
- Then run SIM and switch to the Arellia PL.
- A new set of these files (InstallHistoryPl.xml and InstallHistoryPl.xml.bak) will be created
...
Cause
...
- after installing products when using the Arellia PL.
- After installing the Arellia products close SIM. Rename (suggestion add .Arellia to them) or remove at a separate directory the newly created files (InstallHistoryPl.xml and InstallHistoryPl.xml.bak).
- Then put back in place the initial files (which were either moved or renamed) with the names SIM expects (InstallHistoryPl.xml and InstallHistoryPl.xml.bak).
- Then open SIM and switch back to the Symantec PL file.
Cause
Per Symantec development the SIM history file has been corrupted by . Typically this happens because of manual intervention in the installed solutions. When and if SIM is updated to handle this scenario this article will be updated.